setuid/setgid problem, mail from website not sent

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

setuid/setgid problem, mail from website not sent

Bernd Plagge
Hi

I'm trying to send mail from website mail, or webmail.
However, sending doesn't work,

Log entries:

Jul 06 00:25:45 linde lighttpd[1182]: setuid/setgid: Operation not permitted
Jul 06 00:25:45 linde lighttpd[1182]: /cgi-bin/FormMail.pl: close sendmail pipe failed, mailprog=[/usr/lib/sendmail -oi -t] at (eval 9) line 108.

The courier sendmail program:
s -l /usr/sbin/sendmail
-rwxr-sr-x 1 root courier 59120 Jan 26  2015 /usr/sbin/sendmail


What can I do to solve this problem?

Best regards,
Bernd


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
courier-users mailing list
[hidden email]
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: setuid/setgid problem, mail from website not sent

Gordon Messmer-2
On 07/05/2017 11:33 AM, Bernd Plagge wrote:
> What can I do to solve this problem?


First, "setenforce permissive" and send a message, or examine
/var/log/audit/audit.log to see if this is an SELinux denial.

Next, in permissive mode, use "tail -f /var/log/audit/audit.log | grep
AVC" to watch the log while you send another message.  Take all of the
output and pass it as input to "audit2allow -M lighttpd_sendmail".  That
will create a new SELinux policy module that you can load to allow
lighttpd to send email.


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
courier-users mailing list
[hidden email]
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: setuid/setgid problem, mail from website not sent

Sam Varshavchik
In reply to this post by Bernd Plagge
Bernd Plagge writes:

> Hi
>
> I'm trying to send mail from website mail, or webmail.
> However, sending doesn't work,
>
> Log entries:
>
> Jul 06 00:25:45 linde lighttpd[1182]: setuid/setgid: Operation not permitted
> Jul 06 00:25:45 linde lighttpd[1182]: /cgi-bin/FormMail.pl: close sendmail  
> pipe failed, mailprog=[/usr/lib/sendmail -oi -t] at (eval 9) line 108.
>
> The courier sendmail program:
> s -l /usr/sbin/sendmail
> -rwxr-sr-x 1 root courier 59120 Jan 26  2015 /usr/sbin/sendmail
>
>
> What can I do to solve this problem?
Permissions on the sendmail wrapper should be setuid root, not setgid.



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
courier-users mailing list
[hidden email]
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users

attachment0 (817 bytes) Download Attachment
Loading...