courier-unicode build 20170308 released

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

courier-unicode build 20170308 released

Sam Varshavchik
Download: http://www.courier-mta.org/download.php#unicode

Revised configuration script to enable C++11 builds that should work with  
older versions of gcc.



------------------------------------------------------------------------------
Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
http://sdm.link/oxford
_______________________________________________
courier-users mailing list
[hidden email]
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users

attachment0 (817 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: courier-unicode build 20170308 released

Thomas Hebinck
Hi,

> Revised configuration script to enable C++11 builds that should work with  
> older versions of gcc.

this looks good on ancient Ubuntu 12.04.5 LTS:

/usr/src/courier-unicode-1.5.20170308# g++ --version
g++ (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3

One step during compile:
libtool: compile:  g++ -DHAVE_CONFIG_H -I. -std=c++0x -I.. -I./.. -g -O2 -MT unicodecpp.lo -MD -MP -MF .deps/unicodecpp.Tpo -c unicodecpp.C  -fPIC -DPIC -o .libs/unicodecpp.o

Bye,
Thomas


------------------------------------------------------------------------------
Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
http://sdm.link/oxford
_______________________________________________
courier-users mailing list
[hidden email]
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users
Reply | Threaded
Open this post in threaded view
|

Re: courier-unicode build 20170308 released

Bowie Bailey
In reply to this post by Sam Varshavchik
On 3/8/2017 6:31 AM, Sam Varshavchik wrote:
> Download: http://www.courier-mta.org/download.php#unicode
>
> Revised configuration script to enable C++11 builds that should work
> with older versions of gcc.

Looks good on CentOS 5 and 6.  Configure and make ran with no errors.  
"make check" produced a bunch of output that I don't know how to
interpret, but no obvious errors.

For completeness and for the archives, here is what I had to do on CentOS 5:

yum install gcc44 gcc44-c++
export CC=/usr/bin/gcc44
export CXX=/usr/bin/g++44

--
Bowie

------------------------------------------------------------------------------
Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
http://sdm.link/oxford
_______________________________________________
courier-users mailing list
[hidden email]
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users