Quantcast

Build 20170309 of Courier packages

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Build 20170309 of Courier packages

Sam Varshavchik
Download: http://www.courier-mta.org/download.html

New builds of courier-unicode, courier, courier-imap, sqwebmail, maildrop,  
and cone packages.

• A few more tweaks to the courier-unicode configuration script.

• All other packages are rebuilt against the new courier-unicode package,  
and require the new version for building, going forward.

• courier: switched blacklist lookups to use either TXT or A records instead  
of ANY, depending on the blacklist setting; documentation updated  
accordingly.



------------------------------------------------------------------------------
Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
http://sdm.link/oxford
_______________________________________________
courier-users mailing list
[hidden email]
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users

attachment0 (817 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Build 20170309 of Courier packages

Gordon Messmer-2
On 03/11/2017 11:20 AM, Sam Varshavchik wrote:
> • A few more tweaks to the courier-unicode configuration script.


Building in mock fails on CentOS 7:

https://paste.fedoraproject.org/paste/knoYv8gNHfxhfF3flIz6EF5M1UNdIGYhyRLivL9gydE=


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
courier-users mailing list
[hidden email]
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Build 20170309 of Courier packages

Sam Varshavchik
Gordon Messmer writes:

> On 03/11/2017 11:20 AM, Sam Varshavchik wrote:
> > • A few more tweaks to the courier-unicode configuration script.
>
>
> Building in mock fails on CentOS 7:
>
> https://paste.fedoraproject.org/paste/knoYv8gNHfxhfF3flIz6EF5M1UNdIGYhyRLivL9gydE=

Ok, this actually turned out to be a small typo. Fixed in the just-uploaded  
20170315, and it builds for me.


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
courier-users mailing list
[hidden email]
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users

attachment0 (817 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Build 20170309 of Courier packages

Gordon Messmer-2
On 03/15/2017 06:17 PM, Sam Varshavchik wrote:
> Ok, this actually turned out to be a small typo. Fixed in the
> just-uploaded 20170315, and it builds for me.


courier-unicode does build.  However, I'm unable to build the new
courier package with it installed (also under mock).

https://paste.fedoraproject.org/paste/X1s-KLD0Eaiz9otZerh-wl5M1UNdIGYhyRLivL9gydE=


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
courier-users mailing list
[hidden email]
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Build 20170309 of Courier packages

Sam Varshavchik
Gordon Messmer writes:

> On 03/15/2017 06:17 PM, Sam Varshavchik wrote:
> > Ok, this actually turned out to be a small typo. Fixed in the
> > just-uploaded 20170315, and it builds for me.
>
>
> courier-unicode does build.  However, I'm unable to build the new
> courier package with it installed (also under mock).
>
> https://paste.fedoraproject.org/paste/X1s-KLD0Eaiz9otZerh- 
> wl5M1UNdIGYhyRLivL9gydE=
This should now be fixed in 20170316. All packages rebuilt, including  
courier-authlib which was also affected.


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
courier-users mailing list
[hidden email]
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users

attachment0 (817 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Build 20170309 of Courier packages

Gordon Messmer-2
In reply to this post by Sam Varshavchik
No problems seen yet, on a test host.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
courier-users mailing list
[hidden email]
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Build 20170309 of Courier packages

Alessandro Vesely
In reply to this post by Sam Varshavchik
On Fri 17/Mar/2017 01:25:36 +0100 Sam Varshavchik wrote:

> Gordon Messmer writes:
>
>> On 03/15/2017 06:17 PM, Sam Varshavchik wrote:
>> > Ok, this actually turned out to be a small typo. Fixed in the
>> > just-uploaded 20170315, and it builds for me.
>>
>>
>> courier-unicode does build.  However, I'm unable to build the new
>> courier package with it installed (also under mock).
>>
>> https://paste.fedoraproject.org/paste/X1s-KLD0Eaiz9otZerh-wl5M1UNdIGYhyRLivL9gydE=
>>
>
> This should now be fixed in 20170316. All packages rebuilt, including
> courier-authlib which was also affected.
Compiling still fails for the missing C++ flags, as noted in
http://www.mail-archive.com/courier-users@.../msg38753.html

That patch can work on the configure script directly (removing .ac from the
filename), then it compiles fine...

Out of curiosity, am I the only one stumbling on that?

Ale
--













------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
courier-users mailing list
[hidden email]
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users

signature.asc (484 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Build 20170309 of Courier packages

Sam Varshavchik
Alessandro Vesely writes:

> On Fri 17/Mar/2017 01:25:36 +0100 Sam Varshavchik wrote:
> > Gordon Messmer writes:
> >
> >> On 03/15/2017 06:17 PM, Sam Varshavchik wrote:
> >> > Ok, this actually turned out to be a small typo. Fixed in the
> >> > just-uploaded 20170315, and it builds for me.
> >>
> >>
> >> courier-unicode does build.  However, I'm unable to build the new
> >> courier package with it installed (also under mock).
> >>
> >> https://paste.fedoraproject.org/paste/X1s-KLD0Eaiz9otZerh- 
> wl5M1UNdIGYhyRLivL9gydE=
> >>
> >
> > This should now be fixed in 20170316. All packages rebuilt, including
> > courier-authlib which was also affected.
>
> Compiling still fails for the missing C++ flags, as noted in
> http://www.mail-archive.com/courier-users@.../msg38753.html
>
> That patch can work on the configure script directly (removing .ac from the
> filename), then it compiles fine...
>
> Out of curiosity, am I the only one stumbling on that?
Only the courier-authlib package?

I don't see anything in courier-authlib that needs C++. I think it's only  
the configure script in courier-authlib that's broken. Try build 20170329.



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
courier-users mailing list
[hidden email]
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users

attachment0 (817 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Build 20170309 of Courier packages

Alessandro Vesely
On Wed 29/Mar/2017 13:17:12 +0200 Sam Varshavchik wrote:

> Alessandro Vesely writes:
>> On Fri 17/Mar/2017 01:25:36 +0100 Sam Varshavchik wrote:
>>>
>>> This should now be fixed in 20170316. All packages rebuilt, including
>>> courier-authlib which was also affected.
>>
>> Compiling still fails for the missing C++ flags, as noted in
>> http://www.mail-archive.com/courier-users@.../msg38753.html
>>
>> That patch can work on the configure script directly (removing .ac from the
>> filename), then it compiles fine...
>>
>> Out of curiosity, am I the only one stumbling on that?
>
> Only the courier-authlib package?
Yes

> I don't see anything in courier-authlib that needs C++. I think it's only the
> configure script in courier-authlib that's broken. Try build 20170329.

Could't find 20170329, where is it?

The error I get on make is this:

/bin/bash ./libtool  --tag=CXX   --mode=compile g++ -DHAVE_CONFIG_H -I.  -I
liblock    -I/usr/include/mysql -DBIG_JOINS=1 -fno-strict-aliasing -g -DNDEBUG
-g -O2 -Wall -Ilibs -I./libs -MT authpgsqllib.lo -MD -MP -MF
.deps/authpgsqllib.Tpo -c -o authpgsqllib.lo authpgsqllib.cpp
libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I liblock -I/usr/include/mysql
-DBIG_JOINS=1 -fno-strict-aliasing -g -DNDEBUG -g -O2 -Wall -Ilibs -I./libs -MT
authpgsqllib.lo -MD -MP -MF .deps/authpgsqllib.Tpo -c authpgsqllib.cpp  -fPIC
-DPIC -o .libs/authpgsqllib.o
authpgsqllib.cpp:14:22: fatal error: libpq-fe.h: No such file or directory
 #include <libpq-fe.h>
                      ^
compilation terminated.
Makefile:1352: recipe for target 'authpgsqllib.lo' failed

I reckon anyone having PostgreSQL should experience this error.  The include
file /usr/include/postgresql/libpq-fe.h cannot be found without a proper -I,
which is in CFLAGS but not CXXFLAGS.  The last authpgsqllib.c I have is in
courier-authlib-0.66.4.20160106 and named .cpp thereafter.

Ale


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
courier-users mailing list
[hidden email]
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users

signature.asc (484 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Build 20170309 of Courier packages

Sam Varshavchik
Alessandro Vesely writes:

> On Wed 29/Mar/2017 13:17:12 +0200 Sam Varshavchik wrote:
> > I don't see anything in courier-authlib that needs C++. I think it's only  
> the
> > configure script in courier-authlib that's broken. Try build 20170329.
>
> Could't find 20170329, where is it?

It was where it should've been: http://www.courier-mta.org/download.html#authlib

I noticed before that if you have a long-running browser session and you  
visited the page already you need a force-reload to get an updated page. Or  
quit or restart the browser. Messing around with non-default cache  
expiration headers for just that page isn't very high priority for me, at  
the moment.

> authpgsqllib.cpp:14:22: fatal error: libpq-fe.h: No such file or directory
>  #include <libpq-fe.h>
>                       ^
> compilation terminated.
> Makefile:1352: recipe for target 'authpgsqllib.lo' failed
>
> I reckon anyone having PostgreSQL should experience this error.  The include
> file /usr/include/postgresql/libpq-fe.h cannot be found without a proper -I,
> which is in CFLAGS but not CXXFLAGS.  The last authpgsqllib.c I have is in
> courier-authlib-0.66.4.20160106 and named .cpp thereafter.
Ok, that was something else, that fell out of the C++ rewrite. Made another  
fix to configure.ac, which should fix this one too. Build 20170330 is there  
now.



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
courier-users mailing list
[hidden email]
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users

attachment0 (817 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Build 20170309 of Courier packages

Alessandro Vesely
On Fri 31/Mar/2017 00:28:49 +0200 Sam Varshavchik wrote:

> Alessandro Vesely writes:
>
>> authpgsqllib.cpp:14:22: fatal error: libpq-fe.h: No such file or directory
>>  #include <libpq-fe.h>
>>                       ^
>> compilation terminated.
>> Makefile:1352: recipe for target 'authpgsqllib.lo' failed
>>
>> I reckon anyone having PostgreSQL should experience this error.  The include
>> file /usr/include/postgresql/libpq-fe.h cannot be found without a proper -I,
>> which is in CFLAGS but not CXXFLAGS.  The last authpgsqllib.c I have is in
>> courier-authlib-0.66.4.20160106 and named .cpp thereafter.
>
> Ok, that was something else, that fell out of the C++ rewrite. Made another fix
> to configure.ac, which should fix this one too. Build 20170330 is there now.
20170330 compiles nicely

Thanks
Ale
--












------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
courier-users mailing list
[hidden email]
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users

signature.asc (484 bytes) Download Attachment
Loading...